EU Segmentatation
Incident Report for Boxever
Resolved
This incident has been resolved.
Posted Jun 09, 2021 - 08:28 UTC
Identified
We're investigating an issue with our segmentation service in our EU region affecting June 7th and 8th
Posted Jun 08, 2021 - 09:18 UTC
This incident affected: EU region (Data Processing).