UI unavailable in EU
Incident Report for Boxever
Resolved
This incident has been fixed.
Posted Jul 20, 2021 - 15:35 UTC
Investigating
We're currently investigating issues with our UI affecting the EU region only
Posted Jul 20, 2021 - 12:32 UTC
This incident affected: EU region (UI).